// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<img.*?src="([^"]+\?contextId[^"]+)"[^>]+>)"#).unwrap();
let string = "<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier\" alt=\"Bild Übersicht Router\" title=\"Übersicht Router\" />";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}