import Foundation
let pattern = #"(<img.*?src="([^"]+\?contextId[^"]+)"[^>]+>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img xmlns="http://www.w3.org/1999/xhtml" src="http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier" alt="Bild Übersicht Router" title="Übersicht Router" />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}