re = /^(19|20)\d\d[- \/.](0[1-9]|1[012])[- \/.](0[1-9]|[12][0-9]|3[01])$/m
str = '1999-11-21
2019-01-31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end