# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/000001(?!.*;000001;)/00002/;t' <<< "000001;000001;"