re = /\s(?!(?:[^']*'[^']*')*[^']*$)/m
str = 'some \'text/abc def ghi dddd dddd \''
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result