const regex = /(.*) (KEY) ([^0-9]*)(\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*) (KEY) ([^0-9]*)(\\d+)', '')
const str = `test 74488 hdhd2 768 788 KEY bla gjjjcrs 6448. gfudj778. 2 bla 77545 77890 7754`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}