using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)\s*=\s*(?:""([^""]*?)""|([^ ]*)\b)";
string input = @"a =""First Field"" b=SecondField c3= ""Third field value"" delta = "" e_value = five!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}