#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=\d+$)"
Local $sString = "1111111" & @CRLF & _
"1111111" & @CRLF & _
"1111111" & @CRLF & _
"123something else"
Local $sSubst = "dc.l 0b"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)