const regex = /\S+\[v=\"(kennis)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\/data\/(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+\\[v=\\"(kennis)-(\\w+)\\",g=\\"(\\w+)\\",p=\\"(\\S+)\\"\\]\\\/data\\\/(\\w+)', 'g')
const str = `root/1-825-KennisAPI[v="kennis-adhoc",g="asofdate",p="{"asOfDate":"2017-07-31"}"]/data/as_of_date`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}