const regex = /(\w+)(\s)(\w+)\2(\w+)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)(\\s)(\\w+)\\2(\\w+)', 'igm')
const str = `one two three
422 422 422
100 100 100
10 10 10
oo oo ooo
oa oa oa
ooo ooo oooo
oao aoo ooaa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}