$re = '/\b\w*?\d\w*\b/';
$str = 'This is 4test
of multiple lines. This is 2nd line
This is 3rd line 12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);