using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""((?:""|[^""])*)""";
string input = @"If cmd = ""History Report"" Then
Range(""D2"").Formula = ""=TEXT("""" & createDate & """","""" & Replace(subtitleFormat, """", """""") & """")""
comment = ""This task is completed!""
End If";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}