#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "class=([^=]*)([^(a-z|A-Z|0-9|\-|_)])btn("|([^(a-z|A-Z|0-9|\-|_)]).*")"
Local $sString = " <a href="tel:{{ message.contact_phone }}" data-message-phone-btn class="bottom-bar__btn"><i class="mypro-icon mypro-icon-phone"></i><br>{{ _("Appeler") }}</a>" & @CRLF & _
" <a href="sms:{{ message.contact_phone }}&body={{ body|urlencode }}" data-message-sms-btn class="bottom-bar__btn hide-for-medium-up"><i class="mypro-icon mypro-icon-sms"></i><br>{{ _("SMS") }}</a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")