# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"class=([^=]*)([^(a-z|A-Z|0-9|\-|_)])btn(\"|([^(a-z|A-Z|0-9|\-|_)]).*\")"
test_str = (" <a href=\"tel:{{ message.contact_phone }}\" data-message-phone-btn class=\"bottom-bar__btn\"><i class=\"mypro-icon mypro-icon-phone\"></i><br>{{ _(\"Appeler\") }}</a>\n"
" <a href=\"sms:{{ message.contact_phone }}&body={{ body|urlencode }}\" data-message-sms-btn class=\"bottom-bar__btn hide-for-medium-up\"><i class=\"mypro-icon mypro-icon-sms\"></i><br>{{ _(\"SMS\") }}</a>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.