#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?!foo\()|\)).*"(.*)""
Local $sString = "foo("some str1"); // ignore" & @CRLF & _
"foo2("another string"); // need this" & @CRLF & _
""simple string"; // need this" & @CRLF & _
"foo(L"wide str"); // ignore" & @CRLF & _
"#define NAME "name" // need this" & @CRLF & _
"foo("1") #define NAME "name" // need last one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")