using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?!foo\()|\)).*""(.*)""";
string input = @"foo(""some str1""); // ignore
foo2(""another string""); // need this
""simple string""; // need this
foo(L""wide str""); // ignore
#define NAME ""name"" // need this
foo(""1"") #define NAME ""name"" // need last one";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}