#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^@(\S+\.[^\s]+)$"
Local $sString = "@php" & @CRLF & _
"@python" & @CRLF & _
"@stackoverflow.com" & @CRLF & _
"@google.com" & @CRLF & _
"@stackexchange.com" & @CRLF & _
"@perl" & @CRLF & _
"@regex" & @CRLF & _
"@google.com" & @CRLF & _
"@foo.com" & @CRLF & _
"@bar.com" & @CRLF & _
"@baz.com" & @CRLF & _
"@google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")