using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^@(\S+\.[^\s]+)$";
string input = @"@php
@python
@stackoverflow.com
@google.com
@stackexchange.com
@perl
@regex
@google.com
@foo.com
@bar.com
@baz.com
@google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}