re = /^@(\S+\.[^\s]+)$/m
str = '@php
@python
@stackoverflow.com
@google.com
@stackexchange.com
@perl
@regex
@google.com
@foo.com
@bar.com
@baz.com
@google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end