package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]+\s+[0-9]{6}\s+[0-9]\b`)
var str = `YOUU 410831 0 MEIU 810851 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}