import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\\S+|\\b((?:https?:(?:\\/{1,3}|[a-z0-9%])|[a-z0-9.\\-]+[.](?!js)[a-z]{2,6}\\/)(?:[^\\s()<>\\{\\}\\[\\]]+)(?:[^\\s`!()\\[\\]\\{\\};:'\".,<>?«»“â€â€˜â€™])|(?:(?<!@)[a-z0-9]+(?:[.\\-][a-z0-9]+)*[.](?!js)[a-z]{2,6}\\b\\/?(?!@)))";
final String string = "<a href=\"http://www.google.com\">Google</a>\n"
+ "www.google.com\n"
+ "google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}