import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td>(.*?)</td>|<div.*?>(.*?)</div>";
final String string = "<td>SOME OF THE STRINGS COULD BE HERE</td>\n"
+ "<div style=\"line-height: 100%;margin:0;padding:0;\">SOME STRINGS COULD ALSO BE HERE</div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}