import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d*|0)\\.(\\d*[1-9]+)$";
final String string = "小数点左侧条件1:[1-9]开头的数字后面可以是任何数量的数字\n"
+ "小数点左侧条件2:只有一个0\n"
+ "小数点右侧条件1:任意数量的数字,并且结尾必须是[1-9]\n"
+ "1\n"
+ "1.\n"
+ "1.0\n"
+ "1.10\n"
+ "01.1\n"
+ "01.01\n"
+ "01.10\n"
+ "2.1\n"
+ "2.20\n"
+ "2.01\n"
+ "2.020\n"
+ "3.105\n"
+ "3.01205\n"
+ "2.005\n"
+ "0.02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}