package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)how to`)
var str = `<li><a href="xxx.html" title="xxx">xxx (22)</a></li>
<li><a href="yyy.html" title="yyy">yyy (21)</a></li>
<li><a href="zzz.html" title="zzz">zzz (13)</a></li>
<li><a href="xxx.html" title="xxx">xxx (23)</a></li>
<li><a href="yyy.html" title="yyy">yyy (24)</a></li>
<li><a href="zzz.html" title="zzz">zzz (15)</a></li>
So, this a menu in html. I need to match in order those numbers from the end. Suppose the last line, \`<li><a href="ccc.html" title="ccc">ccc (7)</a></li>\` instead of (7) I would have (6). The regex formula should match this row.
So, the order of the numbers must be taken into account, and regex formula should match only where the number does not match the default number.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}