import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "how to";
final String string = "<li><a href=\"xxx.html\" title=\"xxx\">xxx (22)</a></li>\n"
+ "<li><a href=\"yyy.html\" title=\"yyy\">yyy (21)</a></li>\n"
+ "<li><a href=\"zzz.html\" title=\"zzz\">zzz (13)</a></li>\n"
+ "<li><a href=\"xxx.html\" title=\"xxx\">xxx (23)</a></li>\n"
+ "<li><a href=\"yyy.html\" title=\"yyy\">yyy (24)</a></li>\n"
+ "<li><a href=\"zzz.html\" title=\"zzz\">zzz (15)</a></li>\n\n"
+ "So, this a menu in html. I need to match in order those numbers from the end. Suppose the last line, `<li><a href=\"ccc.html\" title=\"ccc\">ccc (7)</a></li>` instead of (7) I would have (6). The regex formula should match this row.\n\n"
+ "So, the order of the numbers must be taken into account, and regex formula should match only where the number does not match the default number.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}