const regex = /how to/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('how to', 'gm')
const str = `<li><a href="xxx.html" title="xxx">xxx (22)</a></li>
<li><a href="yyy.html" title="yyy">yyy (21)</a></li>
<li><a href="zzz.html" title="zzz">zzz (13)</a></li>
<li><a href="xxx.html" title="xxx">xxx (23)</a></li>
<li><a href="yyy.html" title="yyy">yyy (24)</a></li>
<li><a href="zzz.html" title="zzz">zzz (15)</a></li>
So, this a menu in html. I need to match in order those numbers from the end. Suppose the last line, \`<li><a href="ccc.html" title="ccc">ccc (7)</a></li>\` instead of (7) I would have (6). The regex formula should match this row.
So, the order of the numbers must be taken into account, and regex formula should match only where the number does not match the default number.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}