#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<reference_sequence>(NP|XP|WP)_[0-9]{4,12})\.(?P<version>([0-9]?[0-9])):(?P<prefix>p)\.(?P<ref>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)(?P<start>[1-9][0-9]{0,7})(?P<alt>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)+fs(Ter[1-9][0-9]{0,7}|\*)$"
Local $sString = "NP_001230111.1:p.Arg97ProfsTer12" & @CRLF & _
"NP_001230111.1:p.Arg97Profs*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")