use strict;
my $str = 'NP_001230111.1:p.Arg97ProfsTer12
NP_001230111.1:p.Arg97Profs*';
my $regex = qr/(?P<reference_sequence>(NP|XP|WP)_[0-9]{4,12})\.(?P<version>([0-9]?[0-9])):(?P<prefix>p)\.(?P<ref>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)(?P<start>[1-9][0-9]{0,7})(?P<alt>Ala|Arg|Asn|Asp|Cys|Gln|Glu|Gly|His|Ile|Leu|Lys|Met|Phe|Pro|Pyl|Ser|Sec|Thr|Trp|Tyr|Val|Asx|Glx|Xaa|Xle)+fs(Ter[1-9][0-9]{0,7}|\*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}