using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]([A-Z](?![a-z]))*";
string substitution = @"_$0";
string input = @"CamelCaseForTheWin
ACar
BuyACar
XML
SimpleXML";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}