using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(20\d{2})(\d{2})(\d{2})";
string input = @"aaa_20150229_bbb
aaa_20120229_bbb
aaa_20000229_bbb
aaa_19000229_bbb
aaa_18000229_bbb
aaa_17000229_bbb
aaa_16000229_bbb
aaa_20150130_bbb
aaa_20150131_bbb
aaa_20150430_bbb
aaa_20150431_bbb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}