import re
regex = re.compile(r"([a-zA-Z\:]){4,100}([a-zA-Z0-9]{8}[:-]([a-zA-Z0-9]{4}[:-]){3}[a-zA-Z0-9]{12})")
test_str = ("urn:vcloud:user:2998042f-b91d-4c16-9de8-7feaf5e711a8\n\n\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)