import Foundation
let pattern = #"\s+|(?=\W)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"We have not met, have we?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)