const regex = /(?<=src\s*\=\s*\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\&rel\\=[01]\\"))|(?<=src\\s*\\=\\s*\\")(?<Url>http://www\\.youtube\\.com/(v|embed)/.+?(?=\\"))|(?<Url>^http://www\\.youtube\\.com/(v|embed)/.+?$)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=src\\s*\\=\\s*\\")(?<Url>http:\/\/www\\\\.youtube\\\\.com\/(v|embed)\/.+?(?=\\\\&rel\\\\=[01]\\\\"))|(?<=src\\\\s*\\\\=\\\\s*\\\\")(?<Url>http:\/\/www\\\\.youtube\\\\.com\/(v|embed)\/.+?(?=\\\\"))|(?<Url>^http:\/\/www\\\\.youtube\\\\.com\/(v|embed)\/.+?$)', 'gi')
const str = `Lorem ipsum dolor anka. sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco <span class=""></span > Diabetes laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in Banjo reprehenderit in Anka voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum e. span`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}