#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<p class="TEXT">(?:(?!<br>).)*$"
Local $sString = "<p class="TEST">My mother is at home.<br>" & @CRLF & _
"<p class="TEST">My father is at home.<br>" & @CRLF & _
"<p class="TEXT">My sister is at home.<LLbr>" & @CRLF & _
"<p class="TEXT">My brother is at home.<AAbr>" & @CRLF & _
"" & @CRLF & _
"<p class="TEXT">NEW SCENARIO." & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
"Toto's regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")