use strict;
my $str = '<p class="TEST">My mother is at home.<br>
<p class="TEST">My father is at home.<br>
<p class="TEXT">My sister is at home.<LLbr>
<p class="TEXT">My brother is at home.<AAbr>
<p class="TEXT">NEW SCENARIO.
<br>
Toto\'s regex is very good, but is also finds a the tag ending with <br> (but this in the next line). So, I also want not fo find those kinf of tags that ends with <br> in the next line.';
my $regex = qr/<p class="TEXT">(?:(?!<br>).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}