use strict;
my $str = '1 KB4021558
2 KB4021915
2 KB4022747
2 KB4022884
2 KB4022887
2 KB4024323
2 KB4024402
3 KB3203427
3 KB3203484
4 KB3127894
4 KB3191828
4 KB3203436
4 KB3203438
5 KB4014580
6 KB2756918
7 KB4014570';
my $regex = qr/^[0-9][' ']{7,7}/mp;
my $subst = ' CALL ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";