$re = '/\w+$/m';
$str = '\\\\share\\david\\test\\test.doc
\\\\sharre\\david.jones\\test\\test.doc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);