import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[a-z0-9!#$%&'*+\\/=?^_`\\{|\\}~-]+(?:\\.[a-z0-9!#$%&'*+\\/=?^_`\\{|\\}~-]+)*|\"(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21\\x23-\\x5b\\x5d-\\x7f]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])*\")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21-\\x5a\\x53-\\x7f]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])+)\\])";
final String string = "List of Valid Email Addresses\n\n"
+ "email@example.com\n"
+ "firstname.lastname@example.com\n"
+ "email@subdomain.example.com\n"
+ "firstname+lastname@example.com\n"
+ "email@123.123.123.123\n"
+ "email@[123.123.123.123]\n"
+ "\"email\"@example.com\n"
+ "1234567890@example.com\n"
+ "email@example-one.com\n"
+ "_______@example.com\n"
+ "email@example.name\n"
+ "email@example.museum\n"
+ "email@example.co.jp\n"
+ "firstname-lastname@example.com\n\n"
+ "List of Strange Valid Email Addresses\n\n"
+ "much.â€more\\ unusualâ€@example.com\n"
+ "very.unusual.â€@â€.unusual.com@example.com\n"
+ "very.â€(),:;<>[]â€.VERY.â€very@\\\\ \"veryâ€.unusual@strange.example.com\n\n"
+ "List of Invalid Email Addresses\n\n"
+ "plainaddress\n"
+ "#@%^%#$@#$@#.com\n"
+ "@example.com\n"
+ "Joe Smith <email@example.com>\n"
+ "email.example.com\n"
+ "email@example@example.com\n"
+ ".email@example.com\n"
+ "email.@example.com\n"
+ "email..email@example.com\n"
+ "ã‚ã„ã†ãˆãŠ@example.com\n"
+ "email@example.com (Joe Smith)\n"
+ "email@example\n"
+ "email@-example.com\n"
+ "email@example.web\n"
+ "email@111.222.333.44444\n"
+ "email@example..com\n"
+ "Abc..123@example.com\n\n"
+ "List of Strange Invalid Email Addresses\n\n"
+ "â€(),:;<>[\\]@example.com\n"
+ "justâ€notâ€right@example.com\n"
+ "this\\ is\"really\"not\\allowed@example.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}