# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{(if '?{?)?(.*?)_en-us(.*?)}"
test_str = ("{exp:channel:entries channel=\"\" url_title=\"doors\" limit=\"1\"}\n\n"
	"{exp:playa:children field=\"video_slider\" var_prefix=\"videoslider\"}\n"
	"    {if {videoslider:total_results} != '0'}\n"
	"        {if {videoslider:count}=='1'}\n"
	"            {if '{video_slider_title_en-us}'!='NULL'}\n"
	"                {video_slider_title_en-us}\n"
	"            {if:else}\n"
	"                Videos\n"
	"            {/if}\n"
	"        {/if}\n"
	"        {if video_thumb != ''}\n"
	"        {if:else}\n"
	"            {exp:url_tube:thumbnail src=\"{videoslider:video_file}\" width=\"334\" height=\"150\"}\n"
	"        {/if}\n"
	"        {if video_thumb_title != ''}\n"
	"            {video_thumb_title}\n"
	"        {if:else}\n"
	"            {videoslider:title}\n"
	"        {/if}\n"
	"        {if {videoslider:count}=={videoslider:total_results}}\n"
	"        {/if}\n"
	"{/exp:playa:children}\n\n\n"
	"{/exp:channel:entries}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.