import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http|https):\\/\\/((?:[\\w-]+)(?:\\.[\\w-]+)+)(?:[\\w.,@?^=%&:\\/~+#-]*[\\w@?^=%&\\/~+#-])?";
final String string = "http://www.es.pornhub.com/\n"
+ "http://es.cumlouder.com/?nats=MTkzOC4xLjIuMi4wLjAuMC4wLjA\n"
+ "http://www.pornotube.com/orientation/straight/home/page/1\n"
+ "http://rubias19.com/\n"
+ "http://www.elreyx.com/\n"
+ "http://www.puritanas.com/\n"
+ "http://www.xvideos.com/\n"
+ "http://es.xhamster.com/\n"
+ "http://www.redtube.com/\n"
+ "http://es.cam4.com/\n"
+ "https://es.chaturbate.com/\n"
+ "http://new.bangbros.com/home.htm\n"
+ "http://www.brazzers.com/home/?nats=NDc1NzAzOjQ5MzoyNA,0,0,0,0\n"
+ "http://www.petardas.com/\n"
+ "http://www.poringa.net/\n"
+ "http://foxtube.com/\n"
+ "http://www.tubewolf.com/\n"
+ "http://www.youporn.com/\n"
+ "http://www.putalocura.com/\n"
+ "http://www.serviporno.com/\n"
+ "http://www.toropornohd.com/\n"
+ "http://www.aztepajas.com/\n"
+ "http://pornfun.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}