package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)(_.*?)$`)
var str = `alpha123_4rf_Joe
45beta_Frank
Red5Great_Sam_Fun`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}