import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([^\\)]+)\\)";
final String string = "Der Hund wurde am 01.01.2016 geboren (AB)<br>\n"
+ "Am 05.06.2014 wurde ein anderer Hund geboren (XY) <br>\n"
+ "01.01.2016 ist der Tag der Tage, es war Neujahr (SI)<br>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}