const regex = /\(([^\)]+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([^\\)]+)\\)', 'g')
const str = `Der Hund wurde am 01.01.2016 geboren (AB)<br>
Am 05.06.2014 wurde ein anderer Hund geboren (XY) <br>
01.01.2016 ist der Tag der Tage, es war Neujahr (SI)<br>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}