# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\d+[a-z]|[a-z]+\d)[a-z\d]*"
test_str = ("asdasdas7\n"
"7sdfdf\n"
"a1\n"
"1a\n"
"0001a\n"
"0000a0000\n"
"a-1\n"
"1-a\n"
"a\n"
"1\n"
"eee\n"
"21123124\n"
"aaaa-111\n"
"1 a 6858 ghg 8768-zzt zz zt t-3\n"
"1212231234_sdfs1111dfsdf_ewrwerfwe_sef3325345")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.