// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\d+[a-z]|[a-z]+\d)[a-z\d]*").unwrap();
let string = "asdasdas7
7sdfdf
a1
1a
0001a
0000a0000
a-1
1-a
a
1
eee
21123124
aaaa-111
1 a 6858 ghg 8768-zzt zz zt t-3
1212231234_sdfs1111dfsdf_ewrwerfwe_sef3325345";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}