$re = '/(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>/mi';
$str = '<td>
<P CLASS="abc">
hello</P>
</td>
<P CLASS="abc">
hello</P>
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;