$re = '/>(.*2014.*)<\/year/';
$str = '<title>Record 4m</title><start>2014-02-22</start><year>2013</year><year_0>like 2015 this</year_0><end>2014-03-01</end>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);