using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.org)((?:\/kr\/customer\/account\/forgotpassword\/)(\?.+)?)|((?:\/partners\/boeing\/customer\/account\/forgotpassword\/)(\?.+)?)(?:(?= )|$)";
string input = @"http://google.com/abc
localhost/.
localhost.
localhost/
http://stackoverflow.com/questions/ask
google.com
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something
https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}