re = /(?:[\w+[:digit:],][\w+[:digit:],][\w+[:digit:],])/
str = 'R-P010328-P02-500-1,70'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end