#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!(\w)(\w)\2\1).)*$"
Local $sString = "Match:" & @CRLF & _
"" & @CRLF & _
"aesthophysiology" & @CRLF & _
"amphimictical" & @CRLF & _
"baruria" & @CRLF & _
"calomorphic" & @CRLF & _
"" & @CRLF & _
"Don't Match" & @CRLF & _
"" & @CRLF & _
"anallagmatic" & @CRLF & _
"bassarisk" & @CRLF & _
"chorioallantois" & @CRLF & _
"coccomyces" & @CRLF & _
"abba"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")